The Date of Forum Posts is not correct

identicon
The Date of Forum Posts is not correct
AlexanderLiebrecht@5e3cf8af Tuesday 17th October 2017, 03:08:38

Hello Fred,

I noticed again that the date of forum posts is not correct with me at https://flatboard.wpzweinull.ch. I can not set it in the backend under Config other than the current date.

For example, the date of 16.10.2017 is displayed for posts that are older than 5 days.
You have it here but completely different and so I would gladly have also. How can it fix?

Thanks in advance.
Last modified: Wednesday 18th October 2017, 09:45:54
Administrator locked the discussion.

Replies 4
Fred_4346f29d
Fred  Tuesday 17th October 2017, 08:01:23

Hello Alex,

What happens if you insert this format in configuration:
l jS F o, H:i:s

I tried the format of your forum (Y-m-d), and I'm not that problem.
Did you try to pass your forum in English to see?
Last modified: Tuesday 17th October 2017, 08:03:50

Before ask a question, read the documentation.
Sorry I'm busy right now
Please like in alternativeto.net 👍🏻
╰☆╮Flatboard╰☆╮ is a open source and community contributions are essential to project success!

Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire.
-- E. Snowden

identicon
AlexanderLiebrecht@5e3cf8af  Tuesday 17th October 2017, 11:48:19

 

I can only set a correct date in the backend under Config. If I remove the date and set nothing, message "to short/to long" comes.

Here is another screenshot.

image

Fred_4346f29d
Fred  Tuesday 17th October 2017, 13:50:46

Haa OK I understand better now.
I use Firefox as the main browser, and it does not propose a calendar with per-formatted date.
With your preview screen I understand better.

Please open config.php, search this line:
HTMLForm::text('date_format', $config['date_format'], 'date', '', 'date_format_placeholder').

and replace by:
HTMLForm::text('date_format', $config['date_format'], 'text', '', 'date_format_placeholder').

With this fix you can post more date format.
I fix this for next version, thank wink
Last modified: Tuesday 17th October 2017, 13:55:13

Before ask a question, read the documentation.
Sorry I'm busy right now
Please like in alternativeto.net 👍🏻
╰☆╮Flatboard╰☆╮ is a open source and community contributions are essential to project success!

Prétendre que votre droit à une sphère privée n'est pas important parce que vous n'avez rien à cacher n'est rien d'autre que dire que la liberté d'expression n'est pas essentielle car vous n'avez rien à dire.
-- E. Snowden

identicon
AlexanderLiebrecht@5e3cf8af  Wednesday 18th October 2017, 03:24:21

Thank you, Fred. With your code line it worked. Now I have both the date and the time at the forum posts. So I wanted that.

Thank you!