Topic modal

identicon
Topic modal
8359caae Saturday 25th January 2020, 13:38:35

Any way to get the topic/forum selection modal to show on mobile with free version? Or, would I need to buy pro? Looks like it could be JavaScript somewhere ensuring the modal doesn't show at a certain width.

Also, I almost bought pro but PayPal isn't working. You may want to test that and contact their support.

Last modified: Saturday 25th January 2020, 13:39:28

Replies 7
Fred_4346f29d
Fred  Saturday 25th January 2020, 14:04:07

Hi,
The only difference between the pro and free version is the mention "Flatboard pro" and the pack of plugins.
If you have display problems, please tell me the version of the OS and which browser is concerned.
Otherwise I just did a test with Paypal, and I don't have any problem for purchased.

Last modified: Saturday 25th January 2020, 14:05:41
  • Before ask a question, read the documentation.
  • 🎉  Featured as #1 product of the day on Product Hunt
  • Please like in alternativeto.net 👍🏻
  • ╰☆╮Flatboard╰☆╮ is a open source and community contributions are essential to project success!

identicon
6317ba08  Saturday 25th January 2020, 14:26:31

Thanks. It's the bootstrap theme, and it's in Chrome iOS on my iPhone, and on a Chromebook I have (so regular Chrome browser too, latest version). I don't have any other devices to test it on.

As soon as the sidebar hides, the modal hides too. Therefore, there isn't an easy way to post once the screen gets smaller than about 768px. Since the start a discussion button also is not visible on mobile due to the sidebar hiding, I added a new post link to the main menu. So now, on any size screen I can click something to start a new post, but, the modal where you pick the forum only shows at about 768px wide or higher.

As far as PayPal, maybe it's a country thing. I'm in the U.S., I get logged in and get right about to where I can donate then there's an error. Obviously I can work with PayPal on that though. I know PayPal also had a hard time translating to English too... something's not right on their side. It could be costing you more than just my donation if others are having the same issue. Hopefully not though; hopefully it's just me.

Edit: Solved. It all seems to come down to a bootstrap class called d-md-block. Changing this to d-sm-block ALMOST got me to what I needed. But, the default CSS for d-sm-block kicks in at a minimum of 500+ pixels. I needed this modal to show even with screen sizes as small as 400px. So, this is what I did for anyone else who has the same issue. Again this is with the bootstrap theme that Flatboard comes with as of January 2020.

1) Edit sidebar.tpl.php, line 4. Look for d-md-block in the aside class. Change it to d-sm-block. This isn't 100% necessary, one could simply do the next step using the md-block class but, I changed to the small block class since it got me closer to the right pixels.
2) Add to your main.css the following code which is below my disclaimer... (the key is the 376px - you may choose a different measurement, but I just decided to go from the original 576px which was in the bootstrap.css file, down 200px to 376px. This ensures that even on a small iPhone screen, the forum selection modal shows)

Disclaimer: So far, it doesn't seem like this affects anything negatively. But, I haven't thoroughly tested my forum. One day I might discover that this change messed something else up. But, again so far, everything still looks good and now I can post on mobile. One other thing you'll need to do is, in whatever way you choose because I don't have time to explain it right now, add a link somewhere like the main menu which also opens the forum selection modal. Because with the current bootstrap theme, the "Start a Discussion" buttons are also hidden on mobile. As long as you have some web design experience I'm sure you'll figure this out. Good luck, may the force be with you.


@media (min-width: 376px) {
.d-sm-none {
display: none !important;
}
.d-sm-inline {
display: inline !important;
}
.d-sm-inline-block {
display: inline-block !important;
}
.d-sm-block {
display: block !important;
}
.d-sm-table {
display: table !important;
}
.d-sm-table-row {
display: table-row !important;
}
.d-sm-table-cell {
display: table-cell !important;
}
.d-sm-flex {
display: -ms-flexbox !important;
display: flex !important;
}
.d-sm-inline-flex {
display: -ms-inline-flexbox !important;
display: inline-flex !important;
}
}


A final edit: After looking at the code more, I guess one could just move where the forum selection box code currently is (look for it in the sidebar template). Instead of it being within the aside, which hides at a certain pixel, perhaps moving it outside of the aside would be all that is needed. Regardless, I got it working for my forum by following the above steps. But, then I also had to go back and add additional code to ensure other parts of the sidebar still hid on small screens. So, what I did is most likely a more round about, non-recommended way. 😁

At the end of the day, all of this actually makes me like Flatboard even more because of the fact that it is so easy to customize. 😎

Last modified: Saturday 25th January 2020, 15:57:32

Fred_4346f29d
Fred  Saturday 25th January 2020, 17:43:13

  Thank you for your feedback, I understand what you mean.
And you have targeted the problem. The solution is to add this button in the header.php part.
I look at it and put it up for the next version 😉
Edit: Do you have the same probleme with lightBB theme?

Last modified: Saturday 25th January 2020, 17:47:27
  • Before ask a question, read the documentation.
  • 🎉  Featured as #1 product of the day on Product Hunt
  • Please like in alternativeto.net 👍🏻
  • ╰☆╮Flatboard╰☆╮ is a open source and community contributions are essential to project success!

identicon
108b6f71  Saturday 25th January 2020, 19:11:08

The lightbb theme does not have this same issue.

But, now I have another question if you don’t mind. I have the identicon plugin on, and it has been working. But all of the sudden I posted and I got that Anonymous mask as the avatar. Do you know why that happens? Why it wouldn’t just be an indenticon every time?

Is this on purpose for one reason or another, or did the identicon plugin experience an error?

Fred_4346f29d
Fred  Saturday 25th January 2020, 21:33:17

  This avatar image is displayed only when the nickname is not filled in and the hash generated represents only numbers.

I added this possibility in the plugin, but we can easily remove it if you wish.
  • Before ask a question, read the documentation.
  • 🎉  Featured as #1 product of the day on Product Hunt
  • Please like in alternativeto.net 👍🏻
  • ╰☆╮Flatboard╰☆╮ is a open source and community contributions are essential to project success!

identicon
2174dce4  Saturday 25th January 2020, 22:02:17

 

Got it. I kind of like sticking with identicons only personally. But, this is just one opinion. It’s not a big deal.

Again, this is great forum software! Thank you so much for creating and maintaining this! 🙏 It is so quick to set up. Fast. Easy to move from one server to another. Good stuff!

Fred_4346f29d
Fred  Monday 3rd February 2020, 19:37:03

  Thank you for your feedback and using Flatboard 😎

Last modified: Monday 3rd February 2020, 19:47:48
  • Before ask a question, read the documentation.
  • 🎉  Featured as #1 product of the day on Product Hunt
  • Please like in alternativeto.net 👍🏻
  • ╰☆╮Flatboard╰☆╮ is a open source and community contributions are essential to project success!

never shown to the public
Suggested Topics
identicon
bb4d0 started Events?
941 9
identicon
454d888b started solved login
Bug reports
268 1
Want to read more? Browse all categories or view latest topics.